Changeset 401 for AE


Ignore:
Timestamp:
Jul 7, 2009, 2:34:21 AM (10 years ago)
Author:
gumby
Message:
 
File:
1 edited

Legend:

Unmodified
Added
Removed
  • AE/Installer/trunk/source/aeinstallerapp.cpp

    r393 r401  
    111111        TheWindow = mainWindow;
    112112       
    113 #ifndef WIN32
     113#ifdef WIN32
     114         HKEY hKey;
     115         if(RegOpenKeyEx(HKEY_LOCAL_MACHINE, "SOFTWARE\\Microsoft\\.NETFramework\\policy\\v2.0", 0L, KEY_READ , &hKey) == ERROR_SUCCESS) {
     116                 wxMessageDialog* MonoDialogOfDeath = new wxMessageDialog(TheWindow, "You don't have .NET 2.0 installed! .NET is a framework required by the Edition. You can download it from:\nhttp://gumby.oni2.net/dotnet\nPlease install .NET 2.0, then open this Installer again. \n\nWould you like to open the download webpage?",  "AE Installer Alert",  wxYES_NO | wxICON_EXCLAMATION        , wxDefaultPosition);
     117                 if(MonoDialogOfDeath->ShowModal() == wxID_YES) {
     118                        system("start http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5");
     119                 }
     120                RegCloseKey(hKey);
     121                TheWindow->Close();
     122         }
     123#else
    114124        // test for the third-party mono framework, because without it, on Mac, we are up a creek
    115125        char monoCommand[300] = "which mono >> ";
Note: See TracChangeset for help on using the changeset viewer.