Opened 8 months ago

Last modified 8 months ago

#132 new defect

Vago is broken in macOS 10.13

Reported by: s10k Owned by: s10k
Priority: critical Component: Vago
Keywords: Cc:

Description

Application doesn't launch (can't find onisplit).

It is the usual pathing issues that broke after a osx upgrade...

Change History (8)

comment:1 Changed 8 months ago by s10k

Seems to be part of "App Translocation":
https://forum.qt.io/topic/76797/get-app-dir-of-application-on-mac-os-sierra

Time to save onisplit and xmltools in vago bundle? Not sure if that's even possible, argh!

comment:2 Changed 8 months ago by s10k

As described here:
https://apple.stackexchange.com/questions/262570/oddly-randomized-mounted-paths-in-sierra-for-certain-apps

If you do (inside Vago.app dir):
sudo xattr -d -r -s com.apple.quarantine Vago.app/

It will remove the "App Translocation" and Vago will work as normal. Maybe AEI could start applying this command to the tools (when installed)?

comment:3 Changed 8 months ago by Iritscen

Ah yes, my old nemesis, App Translocation. Strangely, this security feature doesn't affect Oni.app when the Intel build is installed on Macs, so I'm not sure why it affects Vago.app. My understanding was that downloading and unzipping an app through the AEI avoids the quarantine. I'll look into this soon.

comment:4 Changed 8 months ago by s10k

I will also try to install vago using AEI in 10.13 to see if in fact it is affected (or if it is only affected when downloaded directly from mod depot).

comment:5 follow-up: Changed 8 months ago by Iritscen

Sorry, I was assuming you were referring to Vago as installed by the AEI, especially since you referenced the AEI in comment:2. Vago does indeed seem to work properly when installed by the AEI; I did a quick test of converting an SNDD.oni file. Without being installed by the AEI, no Mac app will run properly unless signed with a certificate by a registered Apple developer with a paid membership. This has been the case for several versions of macOS now.

comment:6 in reply to: ↑ 5 Changed 8 months ago by s10k

Replying to Iritscen:

Without being installed by the AEI, no Mac app will run properly unless signed with a certificate by a registered Apple developer with a paid membership. This has been the case for several versions of macOS now.

It is entirely possible to run unsigned programs. You can just right mouse click in open and it will ask you if you really want to run the unsigned app. It worked perfectly this way up until the 10.11.

Now with the 10.12 and upwards it is a bit harder, but I already did some research and it isn't impossible to workaround the "App Translocation". Look here if interested, I will probably just add the same tip at startup to Vago users that get locked with "App Translocation".

Last edited 8 months ago by s10k (previous) (diff)

comment:7 Changed 8 months ago by Iritscen

I'm aware of that -- if you look at the read-me for AE Setup or the Intel Oni build on Macs, they tell the user he has to run that 'xattr' command on the app before trying to run it. So yes, you can try to detect the translocation when it occurs and advise the user on how to fix it, but I was just trying to be clear that it will happen for everyone who downloads Vago as an app (as opposed to getting it through the AEI), so you can also do the user a favor and mention it in the read-me so they have a chance of learning about the issue before trying to run it.

comment:8 Changed 8 months ago by s10k

No problem Iritscen. As I said I will add that information at Vago startup on Vago side, if Vago can't write in its own directory.

Note: See TracTickets for help on using tickets.